2004 DX 150 TLRC

by David Sisler
(Corpus Christi, TX)

Engine idles fine and will run fine for 10 minutes or so then begins to stumble at 3000 rpm. Slowed down for a moment then then when I tried to accelerate it would not get back up to speed but would continually surge and stumble, surge and stumble. Turned off motor, restarted and it accelerated fine but then would occasionally stumble (drop rpm momentarily). Slowed down and then when I attempted to accelerate it would surge and stumble until I turned off the motor, restarted and could then accelerate normally. The engine also stumbled when I attempted to accelerate to wide open throttle.

Engine has less than 20 hours on new plugs, new fuel filter and an entire new tank of gas. Injectors were cleaned about a year ago. Boat is lightly used an average of once a month. pumping tank primer bulb does not solve problem. I checked fuel and filter and both appeared fine. On a possibly related note I had an issue with the motor not starting about 2 months ago and realized that somehow I had gotten alot of water in the fuel tank. (Torrential rains in S Tx). Completely drained tank, replaced inline water/fuel separator,drained oil/fuel mixing tank on engine and cleaned inline fuel filter.
My plans are to replace primer bulb, check to make sure that I have adequate fuel flow through the fuel lines and drop some seafoam in the gas as well.
Any ideas on what else to check?

Click here to post comments

Join in and write your own page! It's easy to do. How? Simply click here to return to Yamaha Outboard Forum.